Internet/Email

Converting Email
Address Books

Note: Though Academic Technology and Networks does not officially support address book conversions, this
document is provided as a tool to the many members of the University population who will be, and have been,
changing email programs in recent months. The contents of this document will be regularly updated to keep up
with any changes, but general support, via the many other resources available through ATN, may not always be
available on address book conversions.

Introduction
This document provides directions on importing address books from one email program to another. If you use
more than one email program, or if you are in the process of changing email programs, you will probably want
to import your old address book into your new program. This will save you the trouble of having to retype the
information for each entry into a new address book file. However, if you have a relatively short list of entries in
your current address book, perhaps 25 or fewer, it would probably be easier to simply re-enter the names.
Address Book Basics
• Address Books: An Address Book allows you to store email addresses so that you do not have to
remember the email addresses of people you write to regularly. You can enter individual addresses in the
Address Book or you can organize your address book by groups. Address Books store such information as
first name, last name, nickname, and email address. Depending upon the program in which it is used, an
address book can store other information about each entry, like company affiliation and phone number.
• Fields: Address books separate information about each entry into fields. Generally, each item of
information constitutes a separate field. For example, an entry in Pine would look like this when opened in
a word processing program:
kathy Edwards, Kathy
kathysue@email.com
In this example, the nickname, full name, and email address all represent individual fields.
• Delimiters: Separating each field are keystrokes known as delimiters. Depending upon the program
being used, the delimiters could be commas, semi-colons or tab characters. In order to import an address
book from one IMAP client to another, the fields must contain the delimiters required by the email program
you will be using. In many cases, this means you will have to change the delimiters for the import to be
successful. In the above example, tabs serve as the delimiters between fields.
• Global Replacement Function: This function allows you to replace one type of keystroke with
another. This is especially useful in replacing one type of delimiter with another in a lengthy address book.
To perform this function in Word 97, highlight the Edit menu and select Replace. In the Find What
field, enter the keystroke you wish to replace (in the above example it would be ^t for tab). In the
Replace with field, enter the new delimiter you wish to use. Select Replace All.
The Importing Procedure
The sections of this document are organized according to what program you are importing your address book
into. Each section begins with a general description of the formatting requirements for each of these programs,
followed by additional instructions for converting from specific email programs. Generally, though, each
conversion process follows the same basic steps. First you will open the address book file of the program you
wish to convert in a word processing program such as Word 97. Next, you will replace the old delimiters with
those required by the new program into which you are importing your address book. Finally, after saving the
edited address book as a text file, you will open the program into which you are converting your address book,
and follow the steps for importing.
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Note: The following directions should allow you to import single email address book entries rather easily, but
all of the email programs have difficulty importing group entries. Unless the new email program you will be
using allows you to import your old address book directly (for example, Mulberry allows you the option of
importing Pine directly), you will have to delete your group entries before importing your address book and reenter them in the new program.

Converting to Outlook Express
Before you can import an address book into Outlook Express, it must be in a format that Outlook can read.
Outlook Express will only import a text file with fields separated by a comma delimiter. Outlook does not
require that the first and last names of each entry be separate fields. You can make them separate fields, or keep
them as one field, as long as you use commas as your delimiters. Each address book entry for Outlook Express
should appear in the following format:
joseph,goehring,goehring@email.com,joe
Note: You may add additional fields if you like, such as company or telephone number, but they too must be
separated by commas.
Once you have edited your address book file so that it is in the proper format for Outlook to read (see directions
immediately following the numbered steps below), follow these steps to import it:
1.
2.
3.

4.

From Outlook Express, select the File menu, highlight Import and from the drop down menu, select
Address Book.
Outlook Express will provide you with a selection of file types from which to import. Select the final
line, text file.
Select Browse and locate the old address book file you wish to import. You must have saved this file as a
text file with the extension .csv, for comma separated values (For example, addresses.csv).
Highlight it and click Open.
Now the CSV
Import Window
will prompt you to
match fields from
your
addresses.cs
v file with
available fields in
the Outlook
Express format.
To match the fields
properly, click the
checkbox next to
the field name, and
then select the
appropriate
Outlook Express
field name in the
next window that
follows. Do this
until all the fields
in the
addresses.csv file have been matched with an Outlook Express field.
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Click Finish to begin the import.
To view and edit your imported address book select Tools and Address Book from the Outlook Express
menu.

Before you follow the steps above, however, refer to the specific instructions below to find out how to edit your
old address book file so that it conforms to the proper formatting requirements.
From Pine (Telnet)
Pine’s address book is called .addressbook and needs to be downloaded from your home directory on Isis
(this is the directory you are taken to after selecting option 8 from the Isis menu). See the document Win:
Telnet & FTP (iis 07) for more information about downloading files.
After you have downloaded the address book file, open it in a word processing program such as Word 97. You
will see that Pine’s address book separates its fields using tabs rather than commas. An entry in a Pine address
book looks like this:
kathy Edwards, Kathy

kathysue@email.com

Consequently, you need to perform a global replacement function (see Address Book Basics at the top of
this document) that replaces the tab characters with commas. Your edited version should look like the example
at the beginning of this section, although the fields do not have to be in the exact order.
From Siren
In order to edit your Siren address book in Word, you must first export it. To do this,
open Siren and highlight the Utility menu and select Address Book. Select
Command, then choose Export to ASCII file. Name the file, and choose a
location in which to save it.
Open your Siren address book in a word processing program such as Word 97. The
Siren address book file has fields that are separated by quotation marks and semi-colons. It will look like this:

"joseph";"goehring";"";"";"goehring@email.com";"joe"
Do a global replacement function, replacing the quotation and semi-colon combinations (“;”) with
commas. Then replace the quotation marks (“) that appear at the beginning and end of each line with nothing.
When you finish, each line should look like the example at the beginning of this section, although the fields do
not have to be in the exact order.
From Mulberry
The Mulberry address book is stored locally on your hard drive. If you have not changed the name and location
of your address book, it will be saved in your Mulberry folder under the name Address. Open this file in
Word 97. Like Pine, Mulberry separates fields by tabs and includes the first and last names of each entry as a
single field. Each entry will look like this:
kathy Edwards, Kathy

kathysue@email.com

Again, perform a global replacement function that changes the tab characters to commas. Your edited
version should look like the example at the beginning of this section.
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From Outlook 98
Because Outlook Express and Outlook 98 share address books, there is no need to import your Outlook 98
address book into Outlook Express. If for some reason the address books do not share the same information, you
can make sure they do by opening your address book in Outlook Express, going to the Tools menu,
highlighting Options and selecting Data Share. Make certain that Share contact information option is
selected.
From Eudora
The Eudora address book, called nndbase.txt, is located in the Eudora Mail folder, which is stored locally
on your hard drive. If you have created new address books in Eudora, they will be saved as text files in the
Nicknames folder, located in the Eudora Mail folder. The delimiters separating the fields in this case are single
spaces. An address book entry, when opened in a word processing program, will look like this:
Alias Joe goehring@email.com
In order to import this into Siren, do a global replacement function that changes the single space
delimiters to commas. Then replace the word “alias” with nothing. The entries in your edited address book
should look like the sample entry at the top of this section. Now follow the numbered steps above to import
the address book into Outlook Express.
Note: Eudora is not supported by the IT Response Center.
From Netscape
From the Communicator menu, select Messenger. From the same menu, open your Address Book and
then from the File menu, select Export. Select a name for your address book file and a location in which you
wish to save it. Then in the Save as type box, select comma separated values. Now follow the
numbered steps above to import the address book into Outlook Express.

Converting to Outlook 98
Outlook 98 complicates the importing process with other IMAP clients, but it does import Outlook Express
address books easily. For this reason, it is probably easier to import an address book into Outlook Express and
then import it into Outlook 98. If you do not already have it, download Outlook Express; it is packaged with
Internet Explorer 4.01. After you have imported your old address book into Outlook Express, see the
instructions above, follow these directions to import it into Outlook 98.
1.

2.

3.

4.

5.

From Outlook 98 select
File…Import/Export. The Import and
Export Wizard window will appear.
Select Import Internet Mail and Addresses
and click Next. The Outlook Import Tool
window will appear.
Select Outlook Express. Make sure that only
Import Address Book is checked, and click
Next. The Import Addresses window will
appear.
At the Import Addresses window you are presented
with some options; choose what is appropriate to
you (probably Allow duplicates to be created) and click Finish.
You can review and edit your address book by opening the Contacts file.
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Converting to Mulberry
To import an address book into Mulberry, it must be in a format that Mulberry can read. Mulberry will only
import a text file with fields separated by tabs. Each address book entry for Mulberry should appear in the
following format, with tabs as the delimiter:
joe

joe goehring

joe@email.com

Note: You may add additional fields if you like, but they too must be separated by tabs.

1.

In Mulberry, select Address Book manager from the
Addresses menu. Double-click on the Local folder, find your
address book, highlight it, and click Open. If you have not
changed the name and location of your address book, it will be saved
in your Mulberry folder under the name Address. If you have not
yet created an address book in Mulberry, click the New button in
the upper right hand corner of the Address Book Manager
window and one will be created for you.
2. Now that you have an
address book open, select
the Address menu, go to
Import Addresses, and
from the drop down menu
select Pine.
3. Mulberry will prompt you
to open the appropriate file
to import. Find the folder
in which you have saved the address book file you wish to import,
and open that file.
4. The names from your old address book will now be added to your
Mulberry address book.
5. When you exit Mulberry, you will be asked if you wish to save
the changes you’ve made to your address book. To save these
changes, you must select Yes.

Before you follow the steps above, however, refer to the specific instructions below to find out how to edit your
old address book file so that it conforms to the proper formatting requirements.
From Pine (Telnet)
Because Mulberry is able to import a Pine formatted address book directly, there is no need to edit your Pine
address book in a word processing program. Simply follow the steps above.
From Siren
In order to edit your Siren address book in Word, you must first export it. To do this, open Siren and highlight
the Utility menu and select Address Book. Select Command, then choose Export to ASCII file.
Name the file, and choose a location in which to save it.
Open your Siren address book in a word processing program such as Word 97. The Siren address book file has
fields that are separated by commas and semi-colons. It will look like this:
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"joseph";"goehring";"";"";"goehring@email.com";"joe"

Do a global replacement function, replacing the quotation and semi-colon combinations (“;”) with tabs.
Then replace the quotation marks (“) that appear at the beginning and end of each line with nothing. When you
finish, each line should look like the example at the beginning of this section. From Outlook Express
In order to open your Outlook Express address book in a word processing program you must first export it.
From the Outlook Express main menu, select the File menu, highlight Export, and from the drop down menu
select Address Book. Next, in the Export tool, select the line, text file (comma separated values).
Choose a name for the file, such as outlook.csv, and a location in which to save it. Click Finish. Your
address book file will then be saved as a text file.
Next, open the file in a word processing program. Using a global replacement function, replace the comma
delimiters with tabs. When you finish, each line should look like the example at the beginning of this section.
From Outlook 98
Address book files from Outlook 98 are difficult to import into other IMAP clients. For this reason you should
follow the above directions for importing an address book from Outlook Express. Because Outlook 98 shares an
address book with Outlook Express, the information in each address book will be identical, so nothing will
change if you import your address book from Outlook Express rather than from Outlook 98. If for some reason
the address books do not share the same information, you can make sure they do by opening your address
book in Outlook Express, going to the Tools menu, highlighting Options and selecting Data Share.
Make certain that Share contact information option is selected.
From Eudora
Just as in Pine, there is no need to change the delimiters in an Eudora address book when importing it into
Mulberry. Simply follow the numbered steps above, but instead of selecting Pine in step two, select Eudora.
The Eudora address book, called nndbase.txt is located in the Eudora Mail file, which is stored locally on your
hard drive. If you have created new address books in Eudora, they will be saved as text files in the Nicknames
folder, located in the Eudora Mail folder.
Note: Eudora is not supported by the IT Response Center.
From Netscape
From the Communicator menu, select Messenger. From the same menu, open your Address Book and
then from the File menu, select Export. Select a name for your address book file and a location in which you
wish to save it. Then in the Save as type box, select tab separated values. Now follow the numbered
steps above to import the address book into Mulberry.

Converting to Siren
To import an address book into Siren, it must be in a format that Siren can read. Siren will only import a text
file with fields separated by commas, semi-colons and several other characters. Siren also requires that the first
and last names of each entry be separate fields. Each address book entry for Siren should appear in the following
format, generally with commas or semi-colons as the delimiter:
kathy;Edwards;Kathy;kathysue@email.com
Note: You may add additional fields if you like, but they too must be separated by commas or semi-colons.
Once you have edited your address book file so that it is in the proper format for Siren to read, follow these
steps to import it:
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1.

In Siren Mail, open the address book utility by selecting U t i l i t y and then Addressbook. From the
Command menu choose Import from ASCII File. The Import window will appear.
2. First, click on the delimiters drop down menu which appears in the upper right hand corner of the
window. Select a semi-colon or a comma as your delimiter, depending on which one you chose as your
delimiter when editing the file in Word.
3. Open the address book file you wish to import by clicking on the button Select File to Import.
4. Next you will have to
match the fields. You will
see a divided window; on
the left are the fields for the
Siren address book, on the
right will be the fields
from your old address
book. Click on the
Select File to Import
button and find the file you
wish to import (for
example,
addresses.csv); you
may need to change the
File Type to A l l F i l e s .
Then you need to match
these fields up so that they
are in the proper order--so
that the first name from
your old address book goes
into the First Name field
for Siren, etc. On the left side of the screen, click on the First Name field; on the right side, click on the line
which contains the first name for the entry. Then click on the < - button, and you will see the number of the
item on the right appear in the column on the left. Do this for each field. When you are done, click on the
Import button. You will be asked to choose which group to import the address book into; probably you should
just choose the Entire Group.
Before you follow the steps above, however, refer to the specific instructions below to find out how to edit your
old address book file so that it conforms to the proper formatting requirements.
From Pine
Pine’s address book is called .addressbook and needs to be downloaded from your home directory on Isis
(this is the directory you are taken to after selecting option 8 from the Isis menu). See the document Win:
Telnet & FTP (iis 07) for more information about downloading files.
After you have downloaded the address book file, open it in a word processing program such as Word 97. You
will see that Pine’s address book separates its fields using tabs rather than commas or semi-colons. In addition,
the first and last names in a Pine address book are separated by a comma and constitute a single field, whereas in
Siren they need to be separate fields. An entry in a Pine address book looks like this:
kathy Edwards, Kathy
kathysue@email.com
Consequently, you need to perform a global replacement function (see Address Book Basics at the top of
this document) that replaces the tab characters with semi-colons. Then replace the comma between the last and
first name with a semi-colon. Your edited version should look like the example at the beginning of this
section.
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From Mulberry
The Mulberry address book is stored locally on your hard drive. If you have not changed the name and location
of your address book, it will be saved in your Mulberry folder under the name Address. Open this file in any
word processing program, such as Word 97. Like Pine, Mulberry separates fields by tabs and includes the first
and last names of each entry as a single field. Each entry will look like this:
john

Doe,John

John@email.com

Again, perform a global replacement function that changes the tab characters to semi-colons. Then
replace the comma with a semi-colon. Your edited version should look like the example at the beginning of
this section.
From Outlook Express
An address book from Outlook Express is relatively easy to
import into Siren because it does not require you to replace
delimiters. From the Outlook Express main menu, select
the File menu, highlight Export, and from the drop down
menu select Address Book. Next, in the Export tool,
select the line, text file (comma separated values).
Choose a name for the file, such as outlook.csv, and a
location in which to save it. Click Finish. Your address
book file will then be saved as a text file. You can now
follow the numbered steps above to import it into Siren,
just remember to make sure that in the Siren address book
tool you set the delimiter option to a comma.
From Outlook 98
Address book files from Outlook 98 are difficult to import into other IMAP clients. For this reason you should
follow the above directions for importing an address book from Outlook Express. Because Outlook 98 shares an
address book with Outlook Express, the information in each address book will be identical, so nothing will
change if you import your address book from Outlook Express rather than from Outlook 98. If for some reason
the address books do not share the same information, you can make sure they do by opening your address
book in Outlook Express, going to the Tools menu, highlighting Options and selecting Data Share.
Make certain that Share contact information option is selected.
From Eudora
The Eudora address book, called nndbase.txt is located in the Eudora Mail folder, which is stored locally on
your hard drive. If you have created new address books in Eudora, they will be saved as text files in the
Nicknames folder, located in the Eudora Mail folder. The delimiters separating the fields in this case are single
spaces. An address book entry, when opened in a word processing program, will look like this:
Alias Joe goehring@email.com
In order to import this into Siren, do a global replacement function that changes the single space
delimiters to commas. Then replace the word “alias”, and the single space after it, with nothing. The entries in
your edited address book should look like the sample entry at the top of this section. Now follow the numbered
steps above to import the address book into Siren.
Note: Eudora is not supported by the IT Response Center.
From Netscape
From the Communicator menu, select Messenger. From the same menu, open your Address Book and
then from the File menu, select Export. Select a name for your address book file and a location in which you

Internet/Email: Converting Email Address Books

Page 9

wish to save it. Then in the Save as type box, select comma separated values. Now follow the
numbered steps above to import the address book into Siren.
Warning: Siren address books are sometimes lost when your desktop computer freezes or the application crashes.
To ensure that you never completely lose your Siren address book, we advise that you create a back up of your
address book at least once per week using the Export to ASCII file option. This will create a text file of
your address book that you can refer back to if you address book is lost at some point. (To use this option open
Address Book from the Utility and select Export to ASCII file from the Command menu.)

Converting To Eudora
According to the Eudora website, www.eudora.com, Eudora itself doesn't have a converter that will allow
you to import address books from other email programs. However, a shareware program, located at
http://www.interguru.com/mailconv.htm, is available which will allow you to convert address books
from Pine and some Microsoft email services to Eudora. Note that the maintainer of the page would like a
twenty dollar payment for the service.

Converting to Netscape Mail
Before you can import an address book into Netscape Mail, it must be in a format that Netscape can read.
Netscape is able to import a variety of different address book formats, including Eudora, Outlook 97/98,
Outlook Express, and text files. Netscape will only import a text file with fields separated by a comma or a tab
delimiter. If you are importing a text file into Netscape mail, it should resemble the following entry, although
tabs could also be used as delimiters:
joseph,goehring,goehring@email.com,joe
Note: You may add additional fields if you like, such as company or telephone number, but they too must be
separated by commas or tabs.
Once you have edited your old address book file so that it is in the proper format for Netscape to read (see
directions immediately following the numbered steps below), follow these steps to import it:
1.
2.

From the Communicator menu, select Messenger. Then from the same menu, select Address
Book.
From the File menu select Import. The Netscape Messenger Import Utility will appear and ask you to
select the import format you wish to use. You may choose from Eudora, LDIF File, Outlook
97/98, Outlook Express, or Text File. Select the proper format for the file you wish to import and
click on Next.
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After you have selected the proper format, you will be asked to locate the specific address book file you
wish to import. Enter the location into the Import File box.
There are two options here, depending on what kind
of file you are importing. If you are importing a text
file, you will now have to enter the appropriate
delimiter in the File Format box. From the drop
down menu, select either commas or tabs as your
delimiters. Once you have done this, you will then
be asked to match up the fields so that they are in the
proper order--so that the first name from your old
address book goes into the First Name field for
Netscape, etc. Netscape will provide you with drop
down menus next to each field name from your old
address book file. Select the field name from the drop
down menu that matches the field name of the text to
the left of the menu. When you have finished, click
on Import and the entries from your old address
book will be added to your Netscape address book.
If you are importing a file other than a text file, such
as an Outlook Express address book, you must first
enter its location, although Netscape may be able to
find it for you. You will then be asked which
mailboxes you wish to import. If you wish to only
import your address book, select Skip. On the following screen, click on Finish and your old address
book will be imported into Netscape, usually as a new address book file. For example, if you imported
your Outlook Express address book, it will appear as a separate address book named Outlook Express.

From Pine
Pine’s address book is called .addressbook and needs to be downloaded from your home directory on Isis
(this is the directory you are taken to after selecting option 8 from the Isis menu). See the document Win:
Telnet & FTP (iis 07) for more information about downloading files. Once you have downloaded your Pine
address book, follow steps 1-4 above, entering tabs as your delimiters.
From Mulberry
The Mulberry address book is stored locally on your hard drive. If you have not changed the name and location
of your address book, it will be saved in your Mulberry folder under the name Address. To import this
address book into Netscape, follow steps 1-4 above, entering tabs as your delimiters. If you have problems,
make certain that the mulberry address book is saved as a text file with the extension .txt.
From Siren
In order to edit your Siren address book in Word, you must first export it. To do this, open Siren and highlight
the Utility menu and select Address Book. Select Command, then choose Export to ASCII file.
Name the file, and choose a location in which to save it.
Open your Siren address book in a word processing program such as Word 97. The Siren address book file has
fields that are separated by commas and semi-colons. It will look like this:

"joseph";"goehring";"";"";"goehring@email.com";"joe"
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Do a global replacement function, replacing the quotation and semi-colon combinations (“;”) with tabs.
Then replace the quotation marks (“) that appear at the beginning and end of each line with nothing. When you
finish, each line should look like the example at the beginning of this section. Then follow steps 1-4 above,
selecting tabs as your delimiters.
From Outlook Express
Netscape allows you to import Outlook Express address books directly. Follow steps 1-4 above.
From Outlook 98
Netscape allows you to import Outlook 98 address books directly. Follow steps 1-4 above.
From Eudora
Netscape allows you to import Eudora address books directly. Follow steps 1-4 above.

Additional Resources
An additional resource for address book conversions can be found by pointing your web browser to
http://www.interguru.com/mailconv.htm. This shareware program provides some useful tools to help
you convert among clients such as Netscape, Eudora and Pine.
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Summary Table
Email Program

Delimiters Accepted

Field Names

Mulberry

Tab delimited only

Nickname, Full Name, Email, Company,
Phone Work, Phone Home, Fax, Address,
URLs

Outlook Express

Comma delimited only

First Name, Last Name, Middle Name,
Nickname, Email Address, Home and
Work Address, and many other workrelated fields (Job Title, etc.)

Outlook 98

Comma delimited (much easier to import
using Outlook Express, which shares an
address book with Outlook 98)

Same as Outlook Express

Siren

Semicolon (;), back slash (/), front slash (\),
tilde (~), horizontal bar (|), and comma (,)

First Name, Last Name, Company Name,
Fax Number, Email Address, Alias

Netscape 4.5

Comma or tab delimited text files, but also
imports Eudora, Outlook 97/98, and Outlook
Express files.

First Name, Last Name, Email,
Nickname, Address, City, State, Zip,
Title, and many other work related fields
(Company, etc.)
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